AFCA Forums Home
Home Search search Menu menu Not logged in - Login | Register
AFCA Forums > Antique Fan Collectors Association > Pre-1950 (Antique) > GE kidney fan oscillator hangs up

 Moderated by: Steve Cunningham, Rod Rogers, Larry Hancock
New Topic Reply Printer Friendly
GE kidney fan oscillator hangs up  Rate Topic 
AuthorPost
 Posted: Mon Aug 13th, 2018 01:17 am
  PMQuoteReply
1st Post
Bill Holcombe
Guest
 

Joined: Mon Jul 30th, 2018
Location:  
Status: 
Offline
I have a mid 20s AOU 12 inch fan that runs good, but the oscillator hangs up when running.  If you nudge it, I can loosen up the screw on the bottom of the bell and it makes it a bit easier.  As far as I can tell there are no mossing teeth, and it runs flawlessly except for this one spot it grts stuck at.
The pot metal bell on the bottom of the kidney has some pieces broken off, but the functional parts all appear to remain.  Its in pretty good shape for spending the last 40 years or so up in a hay loft.

Back To Top PMQuoteReply  

 Posted: Mon Aug 13th, 2018 02:17 am
  PMQuoteReply
2nd Post
Bill Holcombe
Guest
 

Joined: Mon Jul 30th, 2018
Location:  
Status: 
Offline
After messing with it some more, the bell part drops while running and I am hoing to assume that has a part in the issue.

Back To Top PMQuoteReply

Current time is 06:05 am  
AFCA Forums > Antique Fan Collectors Association > Pre-1950 (Antique) > GE kidney fan oscillator hangs up Top



Beige Theme By: Di @ UltraBB
UltraBB 1.17 Copyright © 2007-2008 Data 1 Systems
Page processed in 0.1364 seconds (10% database + 90% PHP). 27 queries executed.