AFCA Forums Home
Home Search search Menu menu Not logged in - Login | Register

 Moderated by: Steve Cunningham, Rod Rogers, Larry Hancock
New Topic Reply Printer Friendly
Got a Little Eskimo Today  Rate Topic 
AuthorPost
 Posted: Wed Sep 19th, 2018 07:05 pm
  PMQuoteReply
1st Post
Richard Daugird
AFCA Member
 

Joined: Tue Sep 12th, 2017
Location: Texas City, Between Hou. & Galveston, Texas USA
Status: 
Offline
My friend gave me this.

Back To Top PMQuoteReply  

 Posted: Wed Sep 19th, 2018 07:06 pm
  PMQuoteReply
2nd Post
Richard Daugird
AFCA Member
 

Joined: Tue Sep 12th, 2017
Location: Texas City, Between Hou. & Galveston, Texas USA
Status: 
Offline




Back To Top PMQuoteReply

 Posted: Wed Sep 19th, 2018 07:25 pm
  PMQuoteReply
3rd Post
Richard Daugird
AFCA Member
 

Joined: Tue Sep 12th, 2017
Location: Texas City, Between Hou. & Galveston, Texas USA
Status: 
Offline
Weired, it's a pale blue-green, looks tan in the picture. Runs O.K. on high, medium and low barely move any air. Maybe after I clean the heavy dust off the blades...

Back To Top PMQuoteReply  

 Posted: Thu Sep 20th, 2018 03:47 am
  PMQuoteReply
4th Post
Levi Mevis
AFCA Member


Joined: Tue Feb 24th, 2015
Location: Elkhart, Indiana USA
Status: 
Offline
Rich, I have that same exact fan in my collection, except mine's a Zero, which is made by the same company as yours, which is the Bersted Manufacturing Company. Mine is actually an emerald green color.Your fan will definitely need an oiling, because mine actually pushes quite a bit of aire on all three speeds and I took mine apart and cleaned and oiled it, and it runs like a top on all three speeds.
These fans date to the late 1940s and early 1950s. See picture below to see what mine looks like.






Back To Top PMQuoteReply

 Posted: Thu Sep 20th, 2018 06:34 am
  PMQuoteReply
5th Post
Richard Daugird
AFCA Member
 

Joined: Tue Sep 12th, 2017
Location: Texas City, Between Hou. & Galveston, Texas USA
Status: 
Offline
Yes Levi that is the color of mine.

Back To Top PMQuoteReply  

 Posted: Thu Sep 20th, 2018 06:53 am
  PMQuoteReply
6th Post
Levi Mevis
AFCA Member


Joined: Tue Feb 24th, 2015
Location: Elkhart, Indiana USA
Status: 
Offline
I'm not sure why yours looks tan in your picture but perhaps maybe your  camera might be going bad?

Back To Top PMQuoteReply

 Posted: Thu Sep 20th, 2018 06:59 am
  PMQuoteReply
7th Post
Richard Daugird
AFCA Member
 

Joined: Tue Sep 12th, 2017
Location: Texas City, Between Hou. & Galveston, Texas USA
Status: 
Offline
Weird lighting.

Back To Top PMQuoteReply  

 Posted: Thu Sep 20th, 2018 05:09 pm
  PMQuoteReply
8th Post
Levi Mevis
AFCA Member


Joined: Tue Feb 24th, 2015
Location: Elkhart, Indiana USA
Status: 
Offline
Let me guess, Old Floresecnt lighting?

Back To Top PMQuoteReply

 Posted: Thu Sep 20th, 2018 05:23 pm
  PMQuoteReply
9th Post
Richard Daugird
AFCA Member
 

Joined: Tue Sep 12th, 2017
Location: Texas City, Between Hou. & Galveston, Texas USA
Status: 
Offline
Yes, LED lights hurt my eyes.

Back To Top PMQuoteReply  

 Posted: Thu Sep 20th, 2018 05:30 pm
  PMQuoteReply
10th Post
Levi Mevis
AFCA Member


Joined: Tue Feb 24th, 2015
Location: Elkhart, Indiana USA
Status: 
Offline
Yeah, I'm not a big fan of LEDs either, not only are they more expensive than traditional Incandescent, but they're also have a bizarre flicker that's even worse than florescent lights, that's really hard on my eyes, (I have a seizure disorder and the light flicker gives me a headache).

Back To Top PMQuoteReply

Current time is 03:17 am  
AFCA Forums > Antique Fan Collectors Association > Post-1950 (Vintage) > Got a Little Eskimo Today Top



Beige Theme By: Di @ UltraBB
UltraBB 1.17 Copyright © 2007-2008 Data 1 Systems
Page processed in 0.2129 seconds (36% database + 64% PHP). 28 queries executed.