AFCA Forums Home
Home Search search Menu menu Not logged in - Login | Register
AFCA Forums > Antique Fan Collectors Association > Post-1950 (Vintage) > GE 75423 really slow at slow speed

 Moderated by: Steve Cunningham, Rod Rogers, Larry Hancock
New Topic Reply Printer Friendly
GE 75423 really slow at slow speed  Rate Topic 
AuthorPost
 Posted: Wed Feb 13th, 2019 02:40 am
  PMQuoteReply
1st Post
Ray Vacca
Guest
 

Joined: 
Location:  
Status: 
Offline
Hello everyone,  Just picked up a GE 75423 fan that oscillates fine at all speeds but the lowest speed setting is very slow and has no torque whatsoever. I can stop the shaft by squeezing it with two fingers. Might the cause be a bad winding or dirt or... Fast really works nice and medium is so-so. Any suggestions and where can I get any printed or documented material for this fan? Thanks in advance for your help
Ray
p.s. opened up the oilers and gearbox and the lube was similar to peanut butter consistency

Back To Top PMQuoteReply  

 Posted: Thu Feb 14th, 2019 01:45 am
  PMQuoteReply
2nd Post
Levi Mevis
AFCA Member


Joined: Tue Feb 24th, 2015
Location: Elkhart, Indiana USA
Status: 
Offline
the fan needs to be taken apart cleaned and lubed, especially the oscillator gearbox and the bearings need to be cleaned and the oilers need to have the wicks either cleaned really good or replaced and fresh oil put into the oilers and the gearbox needs feash grease packed in preferably wheel bearing grease.

Back To Top PMQuoteReply

Current time is 10:19 am  
AFCA Forums > Antique Fan Collectors Association > Post-1950 (Vintage) > GE 75423 really slow at slow speed Top



Beige Theme By: Di @ UltraBB
UltraBB 1.17 Copyright © 2007-2008 Data 1 Systems
Page processed in 0.1507 seconds (20% database + 80% PHP). 29 queries executed.